Print

Security Update to TLS 1.1

Security Update to TLS 1.1

 

During January 2016 the eCorner platform that hosts this website will be updated to a security protocol called Transport Layer Security Version 1.1 (TLS 1.1).  This will ensure the highest security standards are maintained for the safety of your data, and accords with the Payment Card Industry (PCI) Security Standards Council best practice.  It is also necessary for older security protocols (that are vulnerable to attack) to be retired and therefore some older web browsers will not be compatible with checkout and payment functions.

This is an industry-wide change that improves the security of on-line payment information worldwide.  You can find more information at Wikipedia.

In summary, affected web browsers include:

  • Internet Explorer (IE) 8 to 10 (unless TLS 1.1 or TLS 1.2 have been enabled)
  • IE 7 and below
  • Chrome 21 and below
  • Firefox 22 and below
  • Google Android OS browser for Android 4.3 and below
  • Apple Safari version 6 and below
  • Mobile Safari for iOS 4 and below

For IE 8 to 10, TLS 1.1 and TLS 1.2 may be enabled from the main menu by selecting Tools > Internet Options > Advanced tab, and by checking “Use TLS 1.1” and “Use TLS 1.2” (uncheck Use SSL 3.0).

For the other older browsers listed, and for your own security, it is best to update to a more recent version of your preferred browser.